Problem:
The Direct Control Access Manager has the ability to test connectivity to the Centrify Identity Platform (i.e. the Centrify Connector) as seen here:
If TLS (Transport Layer Security) 1.1/1.2 is not enabled on the Windows machine running Access Manager, this check may fail. The error message in the Access Manager logfile is similar to:
[ <Unnamed thread> | 8/25/2017 5:51:27 PM ] [ Verbose ] Send request to https://aah0148.my.centrify.com:443/
[ <Unnamed thread> | 8/25/2017 5:51:25 PM ] [ Verbose ] Send request through proxy cps-cloudc-wind2:8080
[ <Unnamed thread> | 8/25/2017 5:51:25 PM ] [ Warning ] Failed to connect to the cloud connector: {0}
[ <Unnamed thread> | 8/25/2017 5:51:25 PM ] [ Warning ] Detail: System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.ComponentModel.Win32Exception: The client and server cannot communicate, because they do not possess a common algorithm
Cause:
Access Manager communicates to the Centrify Connector through the .NET framework. The version that is bundled with Centrify DirectControl is .NET 4.5.2 By default .NET 4.5 does not communicate via TLS 1.2.
Workaround:
The workaround is to enable the .NET to support TLS 1.2. This can be done by installing .NET 4.6 or by modifying the Windows Registry as follows:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001

Resolution:
Centrify Suite 2018 will be bundled with .NET 4.6.2. However, if .NET 4.5 is already present, the installer will not update to .NET 4.6. The 4.6 framework will need to be explicitly installed.