Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-8927: install.sh fails on solaris 10 when upgrading agent to 5.4.1

Centrify DirectControl ,  

10 July,17 at 07:35 PM

Applies to: Centrify Direct Control 5.4.1 on all supported Solaris OS.

Problem: 
When upgrading a solaris machine from 5.4.0 to 5.4.1 the install.sh script fails to upgrade the agent. The following error is seen in the install-client.log:
====
The following files are already installed on the system and are being used by another package:
  /etc/centrifydc/openldap/ldap.conf
  /usr/share/centrifydc/bin/ldapadd
  /usr/share/centrifydc/bin/ldapcompare
  /usr/share/centrifydc/bin/ldapdelete
  /usr/share/centrifydc/bin/ldapmodify
  /usr/share/centrifydc/bin/ldapmodrdn
  /usr/share/centrifydc/bin/ldapsearch
  /usr/share/centrifydc/man/man1/ldapadd.1
  /usr/share/centrifydc/man/man1/ldapcompare.1
  /usr/share/centrifydc/man/man1/ldapdelete.1
  /usr/share/centrifydc/man/man1/ldapmodify.1
  /usr/share/centrifydc/man/man1/ldapmodrdn.1
  /usr/share/centrifydc/man/man1/ldapsearch.1
  /usr/share/centrifydc/man/man5/ldap.conf.5

Installation of <CentrifyDC-openldap> was suspended (administration).
No changes were made to the system.
====
How can this be fixed? 

Cause:
If a previous version of Centrify DirectControl was installed prior to 5.4.0, the install.sh script included in 5.4.1 will make a comparison call with a previous version causing the installation to fail.

Workaround:
A install.sh script is attached to the KB to allow one to upgrade to 5.4.1. 
Note: 
This should not be used for any future upgrades. This is only for upgrading from 5.4.0 to 5.4.1.

Resolution:
This will be fixed in a future release. 
 
Attachments:

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.