Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-8601: The outgoing account is empty on DirectAudit Manager console

Centrify DirectAudit ,  

25 April,17 at 09:46 AM

Applies to: All versions of Centrify DirectAudit

Problem:

The default "Windows Authentication" outgoing account is null. It causes DA agent's getting offline status on Audit Manager console. 

User-added image

Cause:

Empty outgoing account indicates that the backend service account is having trouble reading SQL engine's service account (which happens to be the default outgoing account). 

To understand the outgoing account -

KB-4546: What is the purpose of outgoing account used in DirectAudit


Workarounds:

1, If the DA is in older version of DA (before Suite 2016.1) please ensure SQL server engine is not running under a virtual service account.

User-added image
- If the name is in "NT Service\MSSQLxxx" format then it is virtual service account. 


2, Confirm that the backend service account is a member of sysadmin fixed server role on the SQL server.
- Use following steps to figure out the backend account:

a. Open SQL management studio and connect to the SQL server hosting Management DB.
b. Expand Databases > Management DB > Programmability > Stored Procedures.
c. Right click on any SP and click Properties.
d. On SP Properties page, look at the value set for "Execute as" (under Description); this is the backend service account.



3, Ensure there is a real outgoing account stored in database. 

- Execute the following stored procedure to figure out the stored outgoing account:

dbo.OutgoingAccountGet

a. Open SQL management studio and connect to the SQL server hosting Management DB.
b. Expand Databases > Management DB > Programmability > Stored Procedures.
c. Right click on
dbo.OutgoingAccountGet and "Execute Stored Procedure...".
User-added image


--OR--

- Execute following SQL query to figure out the outgoing account:
* Remember to replace "
DefaultManagementDatabase" with your real management database name. 

USE [DefaultManagementDatabase]
GO
 
DECLARE              @return_value int,
                                @isWindowsAuthentication bit,
                                @username nvarchar(max),
                                @password nvarchar(max),
                                @userSid varbinary(max),
                                @count int
 
EXEC      [dbo].[OutgoingAccountGet]
                                @isWindowsAuthentication = @isWindowsAuthentication OUTPUT,
                                @username = @username OUTPUT,
                                @password = @password OUTPUT,
                                @userSid = @userSid OUTPUT,
                                @count = @count OUTPUT
                               
                                Print @username 
GO



If the result is null, please restart SQL Server service to pull the outgoing account back. 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.