13 April,17 at 10:40 PM
Applies to: Centrify Agent for Windows (DirectAuthorize) Suite 2017 (3.4.0) on all supported platforms.
Problem:
The following error message appears sometimes when selecting SMS or Mobile Authenticator as an MFA mechanism and pressing enter.
Authentication (login or challenge) has failed. Please try again or contact your system administrator.
Cause:
In Suite 2017 Centrify made a security enhancement to protect how MFA answers were stored. This change has a bug which causes random failures when using SMS or Mobile Authentication methods.
Resolution:
Install Centrify Agent for Windows Suite 2017 April Patch (3.4.0.330) or upgrade to Suite 2017.1 (3.4.1).