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KB-8315: When trying to install security patch getting Error Processing database model

Centrify DirectAudit ,  

7 March,17 at 07:39 PM

Applies to:  Centrify DirectAudit 2015.1 and 2016.1


Problem:

Getting error message when trying to apply the security patch from KB-7865: Centrify Customer Advisory - Security Vulnerability with some Stored Procedures in DirectAudit database
 
PS C:\Users\tetsu>PatchDatabase.exe deploy\DIRECTAUDIT

Centrify DirectAudit PatchDatabase Utility (v.1)
(C) Centrify Corporation 2016

Connecting to SQL Server deploy\DIRECTAUDIT.
Connection is okay.

Checking all databases hosted on SQL Server deploy\DIRECTAUDIT.
Error processing database model. Please check logs for more details.

No DirectAudit databases requiring a patch were found on this SQL Server
.

Check log file 'C:\Users\tetsu\AppData\Roaming\Centrify DirectAudit\Log\centrifyda_patchdatabase_2017_3_7.txt' for more
information.


Cause:

The user used to run the patchdatabase.exe script does not have the necessary rights to login/access the database.

Snippet from the log file referenced in the error message output (centrifyda_patchdatabase_2017_3_7.txt):
 
Info: Checking database model.
Warning: Failed to process database model.
Warning: Cannot open database "model" requested by the login. The login failed.
Login failed for user 'CENTRIFYIMAGE\tetsu'.


Resolution:

The PatchDatabase.exe script needs to be run in the context of a user who is a member of sysadmin fixed server role on the database server.

Verify the user being used to run the patchdatabase.exe is a member of sysadmin fixed server role on the database server and then rerun the patchdatabase.exe script.

User-added image


Note:

Please reference the following KB for more information on the security patch:
KB-7865: Centrify Customer Advisory - Security Vulnerability with some Stored Procedures in DirectAudit database

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