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KB-8303: Kerberos throws GSSException when starting Hadoop application

Centrify DirectControl ,  

7 March,17 at 05:51 PM

Applies to: Centrify DirectControl 5.3.1-398 and below on all supported platforms.

Problem: When using Centrify DirectControl for Kerberos infinite renewal a GSSException is thrown when starting a Hadoop application even though the AD user has a valid TGT.

Error: 

GSSException: No valid credentials provided (Mechanism level: Fail to create credential. (63) - No service creds)

Cause: 

Reference link:

https://social.technet.microsoft.com/Forums/office/en-US/9e133251-f347-43b0-b432-8d0e722d47e3/linuxrodc-kerberos-authentication-fails?forum=winserverDS)

As mentioned in the thread, the problem is due to the name-type field not being set in the PA-TGS-REQ, which is a required field for read only domain controller (RODC), without this feild KRB5KRB_AP_ERR_BAD_INTEGRITY will be returned.

After renewing the ticket using "kinit -R", it can be observed in a network trace, KRB5KRB_AP_ERR_BAD_INTEGRITY error is returned when requesting the service ticket.
=========
#14734, TGS-REQ, krbtgt/centrify.com -> krbtgt/centrify.com
#14736, TGS-REP, error-code: eRR-BAD-INTEGRITY (31)
========

Resolution:
This is fixed with Centrify DirectControl 5.3.1-411 and above.

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