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KB-8253: How to find audited sessions in Japanese using Audit Analyzer?

Centrify DirectAudit ,  

22 February,17 at 07:54 AM

Applies to: All versions of Centrify DirectAudit

Problem:

If the end user's working session is in Japanese, the audit session can not be found with the Quick Query on Audit Analyzer to filter with Japanese character. 

User-added image


Cause:


The "quick query" is entirely based on full-text search. There is limitation of full-text indexing (not search) please refer to the Microsoft's website https://support.microsoft.com/en-us/kb/2252955.


Workaround:

Change the full text indexing language to Japanese from English.

SQL Management Studio > dbo.RawData > Right Click > Full-Text index > Properties > Columns > Tag > Language for Word Breaker -> Japanese. 

After modifying the indexing language the session is listed in Audit Analyzer.
User-added image

Note: Changing the word breaker language to Japanese may result into inaccuracies for English search.
Please find more information from https://msdn.microsoft.com/en-us/library/ms142509(v=sql.110).aspx
(All links provided as courtesy.)

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