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KB-7942: APNS Certificate generation through Quick Start wizard does not work if the Apple ID has 2-factor authentication turned on

Centrify Identity Service, App Edition ,   Centrify Identity Service, Mac Edition ,  

3 January,17 at 12:42 PM

Applies to: All versions of Centrify Identity Service, App Edition and Centrify Identity Service, App Plus

Problem:

When an Apple ID with 2-factor authentication turned on is being used in startup wizard for APNS Certificate generation, an error message of "Communication with the service failed. Please try again." can be seen.

APNS error message

2-factor authentication request can be seen on Apple devices associated with the same Apple ID.

2-factor authentication request

Cause:

The workflow behind the APNS certificate generation cannot handle the 2-factor authentication requirements for those Apple ID.

Workaround:

Follow the instructions under
Settings > Mobile > Apple > APNS Certificate to configure APNS instead.

APNS certificate generation through Settings

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