APNS Certificate generation through startup wizard does not work if the Apple ID has 2-factor authentication turned on. Please follow the instructions under Settings > Mobile > Apple > APNS Certificate to configure APNS.
Applies to: All versions of Centrify Identity Service, App Edition and Centrify Identity Service, App Plus
Problem:
When an Apple ID with 2-factor authentication turned on is being used in startup wizard for APNS Certificate generation, an error message of "Communication with the service failed. Please try again." can be seen.
2-factor authentication request can be seen on Apple devices associated with the same Apple ID.
Cause:
The workflow behind the APNS certificate generation cannot handle the 2-factor authentication requirements for those Apple ID.
Workaround:
Follow the instructions under Settings > Mobile > Apple > APNS Certificate to configure APNS instead.