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KB-7674: Users can login locally, but not over SSH. Getting error as: invalid user or password.

Centrify DirectControl ,  

28 October,16 at 05:24 PM

Applies To : All versions of Centrify DirectControl 

Problem:

Users can login locally, but not over SSH.  The error in the log is:


adclient[5370]: INFO AUDIT_TRAIL|Centrify Suite|Centrify sshd|1.0|101|SSHD denied|5|user=spadmin(type:ad,SPAdmin@XYZ.COM) pid=6610 utc=1474890765178 centrifyEventID=27101 status=DENIED service=ssh-connection tty=(no tty) authMechanism=password client=10.21.33.6 reason=AUTH_FAIL_PASSWD(invalid user or password.)

But neither user nor password is invalid and is happening on only one server.

Cause: 

Debug log shows  that Centrify's PAM module has not been called when the user try to ssh to server. In the file
/etc/pam.d/system-auth,
all the lines that has Centrify pam module entries were commented out. 

Resolution:

Edit the file
/etc/pam.d/system-auth to uncomment the following lines and save.

auth sufficient pam_centrifydc.so 
auth requisite pam_centrifydc.so deny 
account sufficient pam_centrifydc.so 
account requisite pam_centrifydc.so deny 
session required pam_centrifydc.so homedir 
password sufficient pam_centrifydc.so try_first_pass 
password requisite pam_centrifydc.so deny 

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