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KB-7515: Integrating BMC Patrol with Centrify DirectControl

Centrify DirectControl ,  

10 October,16 at 11:05 PM

Applies to:
 
All versions of Centrify DirectControl on Solaris 
 
 
Problem:
 
BMC Patrol Monitors all systems with a patrol user account.   ADusers and local account can log in with the patrol user ID and password without issue.   However, when the patrol team executes the program "PatrolCLI" which is an agent interface to the application (it’s a command-line utility), it then prompts the user for his/her password and failed displaying a message stating incorrect password.  
 

Cause:
 
The application PatrolCLI command is not accessing PAM password authentication modules
 
 
Workaround:
 
Configure BMC Patrol to integrate with Centrify as per the following procedure: 

Please note steps 1-3 can be done before or after Centrify Joins to AD

 
1. If the /etc/patrol.d/security_policy directory exists, do the following as the root account:  
a. Make a copy of the ‘site.plc’ file  
# cd /etc/patrol.d/security_policy
 
b. Edit ‘site.plc’ file and add the following line to the [server] stanza and save:  
pamservice = login
 
 
If the /etc/patrol.d/security_policy_v3.0 directory exists, do the following as the root account:
 
a. Make a copy of the ‘site.plc’ file
# cd /etc/patrol.d/security_policy_v3.0
  
b. Edit site.plc file and add the following 2 lines to the [authenticator] stanza and save:
 
[authenticator]
provider = pam
service = login
 
Note: It is possible that both the /etc/patrol.d/security_policy and /etc/patrol.d/security_policy_v3.0 directories exist simultaneously.
 
2. As root, edit /etc/pam.conf or /etc/pam.d/login.conf & comment out the login line with "pam_dial_auth.so.1". 
Note: Item #2 may not be needed in configuration but may be required in some cases. Use only if needed.
 
# vi /etc/pam.d/login.conf
 
Before:
login auth required pam_dial_auth.so.1
 
After:
# login auth required pam_dial_auth.so.1
 
Save the file, but keep the root user session running.
 
 
3. Attempt the login.

 
Resolution:

Since the solution involves configuration on the vendor side only, there is nothing more Centrify can do to resolve beyond the workaround.

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