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KB-7095: Error When configuring or synchronizing Centrify Report Services with Suite 2016

Centrify DirectControl ,  

30 June,16 at 11:29 PM

Applies to:  

Centrify DirectManage on Suite 2016


Problem:  

There has been an issue when configuring Centrify Report Services or during the synchronization, two types of errors may occur:

First Error:

Centrify Report Services Configuration Wizard cannot be completed due to an error occurred:

Failed to install SQL Server on this computer, exit code: 0x80070003; refer to Centrify Knowledge Base article (KB-4589) for more information on the error code you received. Please fix the problem and run Setup again.
 

Second Error:

Not a valid Win32 File Time.  Parameter name: fileTime.



Cause:

The first error maybe due to disk space issue.  

The second error happened when synchronizing AD users and and if any of the time-stamp is negative.  It is in one of the following time-stamps:
 

  • lastLogonTimestamp
  • accountExpires
  • lockoutTime
  • pwdLastSet

Workaround:

If the 'accountExpires' attribute is '-1', apply the workaround as follow:
  1. Start ADUC and open property pages for the problem user.
  2. Set the "Account expires" to any value (not "Never"), click Apply.
  3. Set it back to "Never" and apply again.  This should reset 'accountExpires' to 0 or 0x7fffffffffffff.  Both means "Never expire"

Verify if the Report Service can synchronize successfully after doing the steps above.


Solution:

This issue is now fixed in Suite 2016.1 (CDC 5.3.1).
 

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