30 June,16 at 01:12 PM
Applies to:
Centrify Server Suite Enterprise edition 2013 and higher.
Problem:
When Deployment Report is run, it shows multiple installations, DirectAudit 1.x and DirectAudit 2.x+, on the 'DirectAudit Credential Configuration' page, and depending on whether the old database is online or not, it may show an error connecting to the older DirectAudit 1.x database.
Cause:
If DirectAudit installation was upgraded from DirectAudit 1.x to DirectAudit 2.x or higher, the Active Directory domain will continue to have information of both DirectAudit 1.x deployment and the newer DirectAudit installation.
Workaround:
When running Deployment Report, you can choose the option to "continue running the report without fixing all failed connections" on the 'DirectAudit Credential Configuration' page. Selecting this option will make the Deployment Report ignore the old DirectAudit 1.x deployment.
Resolution:
If the old DirectAudit 1.x deployment is no longer needed and no collectors are actively serving it, you can ask your Active Directory administrator to delete the service connection point object that's representing the DirectAudit 1.x deployment. To search for such objects in Active Directory, please use an LDAP filter that searches for all objects of type 'serviceConnectionPoint' and whose cn is using 'directaudit_<GUID>' format
For example, an LDAP filter like one given below should be able to list all DirectAudit 1.x deployments in the domain,
(&(objectClass=serviceConnectionPoint)(cn=directaudit_*))