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KB-6850: Collector cannot contact SQL Database and receiving ‘Cannot generate SSPI context’ in log

Centrify DirectAudit ,  

4 May,16 at 01:35 AM

Applies to All versions of Centrify DirectAudit for Windows

Problem:

The setup in SQL is correct and confirmed the following:

1. SPN set correctly and no duplicate SPNs

2. FQDN lookup and reverse lookup are fine.

3. kerberos ticket was cache for SQL service

However, the collector still cannot connect to SQL server with the error “You cannot connect to SQL Server. Please make sure the Service Principal Name (SPN) for the SQL Server instance is valid”. Also, the SQL server cannot be restarted due to authentication failure.

Below log messages can be seen in collector log:

====

[2016-04-21 14:54:56.006 -0500] collector.exe[2104,5] Error: ExceptionHandler.GetException: Sql error occurs - Number: 0

[2016-04-21 14:26:39.850 -0500] collector.exe[692,5] Error: ExceptionHandler.GetException: Message: Cannot generate SSPI context.

====

Cause:

One of the possible cause for seeing this error is that the SQL service account password got changed/reset and SQL server engine had not restarted. There are other possible reasons behind this error.

Resolution:

Using 'SQL Server configuration manager' to update SQL service account password and restart SQL server engine.

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