Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-6843: DirectAudit database upgrade fails when there are more than 64 databases

29 April,16 at 02:22 PM

Applies to: 

All DirectAudit versions on all supported Windows platforms. 


Problem: 

When upgrading DirectAudit databases through the database maintenance wizard (setup.exe /database), the wizard throws an unexpected error:

Unexpected error occurred. Please contact Centrify support.

System.Not.Supported.Exception: The number of WaitHandles must be less than or equal to 64.
  

User-added image



Cause: 


If total number of attached Audit Store Databases is 64 or more, the above error is thrown. This is due to the way database versions are loaded. 

When database versions are loaded, a thread is spawned for each database from the thread pool and calls WaitHandle.WaitAll, which has a theoretical limit of 64 handles. 


Workaround: 

In Audit Manager console, Detach databases to lower the number of databases to less than 64. 


Resolution: 

This issue will be fixed in later versions of DirectAudit. 
 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.