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KB-5962: Permission error when restarting Collector

Centrify DirectAudit ,  

12 April,16 at 11:44 AM

Applies to:

Centrify DirectAudit Suite 2015.1
 
Problem:

Getting permission error when restarting DirectAudit collector shown as below:
The Collector is not able to use the database Data Source= MySQLserver.mycompany.com;Initial Catalog=AuditStore-Aug-1-2014-2014-08-02: You do not have sufficient permissions to connect to the SQL Server
 
SQL server logs show:
Error: ExceptionHandler.GetException: Server: MySQLserver.mycompany.com 
Error: DatabaseVersionControl.LoadDatabaseVersion: Error occurs when loading database version of database with server=, database=, database type=AuditStoreDatabase, error=You do not have sufficient permissions to connect to the SQL Server. 
Error: ExceptionHandler.GetException: Sql error occurs - Number: 18456 
Error: ExceptionHandler.GetException: Message: Login failed for user 'CENTRIFYCLOUD\VGA-DC2$'

Error: ExceptionHandler.GetException: Help link: 
Error: ExceptionHandler.GetException: Source: .Net SqlClient Data Provider 
Error: ExceptionHandler.GetException: Procedure: 
Error: ExceptionHandler.GetException: Server: MySQLserver.mycompany.com

Error: DatabaseVersionControl.LoadDatabaseVersion: 
Error occurs when loading database version of database with server=, database=, database type=AuditStoreDatabase, error=You do not have sufficient permissions to connect to the SQL Server

 
SQL Current log message display:
Login failed for user CENTRIFYCLOUD\VGA-DC2$.Reason Could not find a login matching the name provided [CLIENT: 129.17.10.1]
Error 18456,Severity 14. State 5.
 
From Unix adclient host when running ‘dainfo –diag’, the following message at the end show:
Failed to connect to Audit Store Login failed for ‘CENTRIFYCLOUD\VGA-DC2$’
 
Cause:

The sid mismatch in the database than the actual sid of the computer account.  This can happened if the machine leave the domain and rejoin to the domain and sid changed or it can also mismatch on the SQL server.  Another possibility somebody might rejoin the machine and restore an old snapshot.

 
Resolution:
  1. Open SQL Server Management Studio.  Expand ‘Security’, expand ‘Login’ highlight the user CENTRIFYCLOUD\VGA-DC2$, right click and select ‘Properties’, click on User Mapping, verify if it is map correctly (map box is checked?).
 
  1. If step 1 is done and problem still recur, Centrify recommend to delete the login and recreate the user.
To delete the login and recreate the user do the following steps:
Do the same step as Step 1, under ‘User Mapping’, uncheck the box under ‘Map’ for User 'CENTRIFYCLOUD\VGA-DC2$’to remove all the mapping.  Click OK.
 
  1. Go back to highlighting the user CENTRIFYCLOUD\VGA-DC2$ on the left menu, then right click, and select ‘Delete’, another window will pop-up, highlight the object to be deleted, than click ‘OK’.  Then confirm by clicking ‘OK’ again.
 
 
  1. Go back to the left menu, expand ‘Databases’, expand ‘AduitStore’, expand ‘Security’, expand ‘Users’. 
 
  1. Launch Centrify DirectAudit Collector Control Panel, select button ‘Configure’, proceed with Collector Configuration Wizard.  Once completed, it should work.  To verify if user login is recreated, expand ‘Databases’, expand ‘AduitStore’, expand ‘Security’, expand ‘Logins’, right click and select ‘Refresh’, verify if the user login CENTRIFYCLOUD\VGA-DC2$ is there.

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