Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-5889:enQuesta application authentication issue after upgrading Centrify agent to 5.2.3

Centrify DirectControl ,  

29 June,17 at 10:16 AM

Problem: 

SSO through enQuesta application fails after upgrading Centrify  agent to 5.2.3

Error:

"License Server problem, unable to verify license.
Have not been able to verify within grace period.
Crypto algorithm could not be negotiated.
Program will close.
Please contact your dealer for assistance."


Background:
In the Centrify Open SSH 6.7p1  included in 5.2.3 agent package the default supported Ciphers are:
aes128-ctr,aes192-ctr,aes256-ctr,chacha20-poly1305@openssh.com

In the Centrify OpenSSH 6.2p2  included in the 5.1.3 agent package the default supported ciphers are:
aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se

A number of version 2 ciphers have been disabled in the 6.7p1-1 release of openssh which is included in the 5.2.3 version  including the following:
3des-cbc
blowfish-cbc
cast128-cbc
arcfour
arcfour128
arcfour256
aes128-cbc
aes192-cbc
aes256-cbc
rijndael-cbc@lysator.liu.se<mailto:rijndael-cbc@lysator.liu.se>

That leaves the following available:
aes128-ctr
aes192-ctr
aes256-ctr
aes128-gcm@openssh.com<mailto:aes128-gcm@openssh.com>
aes256-gcm@openssh.com<mailto:aes256-gcm@openssh.com>
chacha20-poly1305@openssh.com<mailto:chacha20-poly1305@openssh.com>

Resolution:
Add the following  line in the /etc/centrifydc/ssh/sshd_config should allow the enQuesta application to  
successfully SSO to the 5.2.3 system.

# Ciphers and keying
Ciphers blowfish-cbc,aes128-cbc,aes192-cbc,aes256-cbc,aes128-ctr,aes192-ctr,aes256-ctr

 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.