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KB-5345: Connection test shows failure when registering with Centrify Cloud Management Suite 15.4

Centrify DirectControl ,   Centrify Identity Service, App Edition ,  

12 April,16 at 11:07 AM

Applies to: Centrify Identity Service 15.4

Problem:

When installing Centrify Cloud Management Suite 15.4, the connection test in the Cloud Connector Configuration Wizard fails. Clicking “Next” from the following screenshot shows that the registration actually finished successfully and the Cloud Connector is working smoothly as expected.

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Why did the connection test fail?
 

Cause:

Centrify Cloud Service 15.4, altered the registrationUrl key in the registry which in turn caused the connection test to falsely return a connection failure. Since the main Connector service does account for the registry change, actual functionality was not compromised - only the connection test was affected.

 
Workaround:

There are two workarounds to handle the situation:
 
Option 1:
  • Modify the registrationUrl in the registry and add "/transport_rpc.svc" to the end of the value there. 
  • The string registrationUrl can be found under "HKEY_LOCAL_MACHINE\SOFTWARE\Centrify\Cloud"
    • Name: registrationUrl
    • Data: https://cloud.centrify.com/transport_rpc.svc
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Option 2:
  • In Cloud Connector Configuration Wizard's "Enter the Centrify Cloud Connector Administrator Credentials" page:
    • Click "Advanced"
    • Then click "OK". 
  • This will also update the registrationUrl in the connection test to the expected value.
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Resolution:

This is targeted to be fixed in a future version of the Centrify Identity Service.

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