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KB-5095: After updating a user's home folder path in AD yields "The home folder for user X isn't located in the usual place or can't be accessed" upon logging in

Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:14 AM

Applies to: Centrify DirectControl on Mac OS X 

Problem:

After updating a user's home folder path in Active Directory, the user attempts to log in and is shown the following error message: "The home folder for user 'X' isn't located int he usual place, or can't be accessed."

Cause:

This error occurs when a user's home folder path is updated in Active Directory, but the local machine does not know that the change has been made.  The cause of this error can be verified by:
  • Opening up Terminal.app (located in /Applications/Utilities/Terminal.app) and running adquery user -h user.name [user.name is replaced with the actual username of the AD user]
  • ​This will print the home folder path for the user that the machine currently sees as assigned.  If the output of the command doesn't match the path specified in the user's profile within AD, then the error message will appear upon login.
Resolution:

In order to update the home folder path that the local machine sees, the AD cache will need to be flushed and rebuilt.  This can be done by:
  • Open Terminal.app and type sudo adflush and then hit enter.
  • Then  run adquery user -h user.name in order to verify that the home path the machine sees, matches the home path specified in the profile section of the user's account in AD.

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