Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-4877: Deployment Manager fails to detect OS X 10.10 Yosemite

Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:17 AM

Applies to: Centrify Deployment Manager with all versions of OS X 10.10

Problem:
  • Version 5.2.1-351 of the Mac agent has been downloaded (the minimum required for Yosemite support) and the latest manifest file has been imported into Deployment Manager.
  • However, after adding a Mac OS 10.10 (Yosemite) machine to Centrify Deployment Manager, the Operating System is still displayed as Unknown or Unsupported.

Cause: 

Deployment Manager can usually be kept up to date by updating its manifest file, however some OS platform updates also require an update of Deployment Manager itself. See the following KB for more information:
OS X 10.10 was released by Apple just after Centrify Suite 2014.1 itself was released, this meant the original version of Suite 2014.1 did not include support for OS X Yosemite. Shortly after Yosemite was made public, Centrify refreshed the 2014.1 package with the updated components to support OS X 10.10.

Original Deployment Manager 2014.1: Version 5.2.0.220
Refreshed Deployment Manager 2014.1: Version 5.2.0.405


Resolution:

Option 1:
Option 2:
  • To avoid having to download the whole Centrify Suite installer package again, Centrify DirectManage Express can also be used to deploy to the latest versions of OS X.
  • (Centrify DirectManage Express is essentially just the Deployment Manager component of the full Centrify Suite by itself)
  • http://www.centrify.com/express/identity-service/mac-download/​

After updating Deployment Manager, the analysis tools and agent packages will need to be re-downloaded in Step 2:
 
User-added image
Re-analyze the Yosemite systems and the rest of the deployment steps should now successfully complete.


Related Articles:

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.