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KB-4669: Starting Centrify agent may cause timed out on Solaris platforms

Centrify DirectControl ,  

21 December,15 at 06:47 PM

Applies to: Centrify DirectControl 5.x on Solaris 10 platforms

Problem:
After upgrading to 5.1.3 on Solaris, starting Centrify agent times out and the Centrifydc mode is in unavailable status

Cause:
By default svcadm has a 60 seconds timeout value. 

So if adclient has not finished starting up within 60 seconds, svcadm will kill adclient and therefore you will see centrifydc in "unavailable mode". 

In the latest version of the agent, we will try to build up the cache when adclient first started up and this could be the reason why adclient start up is taking more than 60 seconds. 

Resolution:

Increase the timeout value for svcadm with following command 

svccfg -s centrifydc setprop stop/timeout_seconds=300 
svccfg -s centrifydc setprop start/timeout_seconds=300 
svccfg -s centrifydc setprop refresh/timeout_seconds=300 

svcadm refresh centrifydc 


Then try start up centrifydc again: 

svcadm clear centrifydc 
svcadm enable centrifydc 

 

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