Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-4442: Office 365 application error: "Cannot convert default domain to SSO"

Centrify Identity Service, App Edition ,   Centrify Identity Service, App Plus ,  

3 March,17 at 03:47 PM

Applies to: Centrify Identity Service



Problem:

When an Administrator adds the Office 365 WS-Fed app template from the Admin Portal catalog and attempts to federate a domain, the following error message is displayed:
 
  • Cannot convert default domain to SSO

This error prevents successful deployment of the application to users as the Office 365 domain is not converted from "Managed" to "Federated" status.



Cause:

The above error can be presented if the Office 365 Admin Portal has the externally available domain configured to be used as the default domain. 



Solution:

Be sure that your custom, externally accessible domain is not specified as the default domain. Otherwise, single sign-on may not work. Instead, set the default domain to the one that has the company.onmicrosoft.com format.

Be sure to review the complete Office 365 deployment checklist in Centrify Online Help for more information.


To set the Office 365 default domain:
  1. Log in to the Office 365 administrative portal at https://login.microsoftonline.com
  2. In the upper-right corner of the administration dashboard, click your company name.
    Your organization’s settings display.
  3. In the Default Domain list box, select the domain that has the company.onmicrosoft.com format.
    • Note: Changing this value does not impact any current domains or user access to Office 365 mailboxes.
  4. Click Save
  5. Re-attempt federating the Office 365 domain

User-added image

User-added image



For additional information not covered in this guide or troubleshooting assistance, please review Centrify Online Help or visit the Customer Support Portal at https://www.centrify.com/support/

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.