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KB-4371: “A database operation error occurred” & “Invalid database” error when opening Audit Manager

Centrify DirectAudit ,  

12 April,16 at 11:41 AM

Applies To:
 
All versions of Centrify DirectAudit
 
Problem:
 
When opening DirectAudit Manager, you get a message saying:
 
“A database operation error occurred. Please contact your administrator to make sure the remote database is accessible and working properly”
 
Or 
 
“Invalid database. The database owner does not have Authenticate Server permission on the SQL Server”
 
Cause:
 
There are two reasons why this can occur.
 
(1) The trustworthy flag for the database has been reset to False. This typically happens if you restore a database from a backup or detach/attach the database.
 
(2) The owner of the database is not ‘sa’

Resolution:

(a) In Microsoft SQL Server Management Studio, run the following query to check if trustworthy flag is set to true or false:
select name, is_trustworthy_on, SUSER_SNAME(owner_sid) from sys.databases order by name

1= True
0 = False

If your database trustworthy flag is set to '0' then you can run the following query command to set it to '1'
ALTER DATABASE [DB_NAME] SET TRUSTWORTHY ON 
 
Where [DB_NAME] is the name of your database.

For example:

ALTER DATABASE [SupportInstallation] SET TRUSTWORTHY ON

(b) In the same window, you can see if 'sa' is the owner. If 'sa' is not the owner of the database, you can run the following query command to set 'sa' account as the owner:
sp_changedbowner [sa]

User-added image
 

 

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