Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-41203: Port Scan Discovery labels UNIX systems as GenericSSH systems

Privileged Access Service ,  

25 September,20 at 07:00 PM

Problem:
After running a Port Scan Discovery, UNIX systems are being returned as a GenericSSH system

Cause:
The system is labeled as a GenericSSH system because of the use of the # symbol multiple times in the Banner message or Message of the Day (MOTD) on the system. See the example below:


#########################################################################
#              ********  Private System Warning! ********               #
# This is a private computer network system.  This system is for use    #
# only by authorized users.  If you do not have authorization, you must #
# discontinue use at once.                                              #
#########################################################################


When discovery runs it sends various commands to the system to try and determine what type of system it is reaching out to. For a UNIX system, it sends the command uname. When the banner or MOTD ends with a line of number signs, discovery is unable to parse the data correctly and will incorrectly label the system as a GenericSSH system.

Workaround:
Below are the current workarounds to resolve this issue:
  1. Disable the Banner or MOTD temporarily when running discovery.
  2. Replace the number symbols (#) with another symbol such as asterisks (*) or dashes (-)
  3. Implement a .hushlogin file for the discovery account.

Solution:
This will be fixed in a future release of Centrify Privileged Access Service.

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.