Applies to: All versions of Centrify DirectControl using Zone Provisioning Agent.
Problem:
If the samAccountName / login name has an invalid character in it, Zone Provisioning Agent (ZPA) will replace the invalid character with an underscore (_).
For example if the login name is joe.smith, ZPA will replace this with joe_smith. This will cause an authentication conflict if a user home directory is configured for a network home directory. A network home directory will typically display the samAccountName.
Cause:
This behavior in ZPA is by design and is configurable.
Resolution:
Under the ZPA Provisioning tab, there is a settings gear icon next to the Login name field. Add the 'character' in the 'Valid characters for UNIX names field, To get to this tab;
- Open Centrify Access Manager
- Right click the zone in which the user belongs
- In the side menu click, "Properties"
- Navigate to the "Provisioning" tab.
After saving the Unix character, either:
- I. Remove and then add the users back into the AD group (This is the source group set in the ZPA provisioning tab).
- II. Or disable ZPA in Zone Provisioning and delete the user profiles from the Zone. Then re-enable ZPA provisioning to regenerate the update zone profiles. This will reflect the new changes in the login name.
Note: Make sure the ZPA service is restarted to take effect.