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KB-30183: Connector auto-update failed with error "Download job state: Suspended"

Privileged Access Service ,  

15 April,20 at 08:58 AM

Applies to: All versions of Privileged Access Service

Problem: 

The auto-update does not happen when new Connector is released with below error message recorded in connector log. 


2020-01-13 22:34:48,453 [P-Centrify.Cloud.Core.ProxyHost.exe-3656|XXXXXXX|48971a3e-56b1-4919-931b-5249956d64ae|15ae4e186ec9420fb29389b1abd5d7ad|DefaultQuartzScheduler_Worker-3|2582685819|INFO ] AutoUpdater: Download job state: Suspended


Cause:

BITS is used for Connector auto-update and according to 
Microsoft the installation package will be transferred only when the job owner is logged on and a network connection is established. Job owner is the service account used to launch the Connector service on the Windows machine. 

User-added image

By default this Log on as account is Local System which is always logged on so BITS can download the update package successfully.
The BITS job will be suspended if the Centrify Connector is configured to use AD user whereas this AD user logs off or if the network connection is lost when auto-update is triggered.

> Get-BitsTransfer -AllUsers | select *

JobId : d30793f8-b9bb-4103-81e0-87cecaacdfb8
DisplayName : Download auto-update package for Centrify
Description :
TransferType : Download
JobState : Suspended
TransferPolicy : Standard
OwnerAccount : DOMAIN\SERVICE_ACCOUNT



Resolution: 

Option 1: Let 
DOMAIN\SERVICE_ACCOUNT is logged on in the period of  auto-update. And perform below 2 commands to make sure there is no suspended job. 
> Get-BitsTransfer | Remove-BitsTransfer
> Get-BitsTransfer -AllUsers | select *
 

Option 2: Change the Log on as account from
DOMAIN\SERVICE_ACCOUNT to Local System account. 

Option 3: Switch back to the old fashion to download the package using AppLife Update by adding a registry value. 

[HKEY_LOCAL_MACHINE\SOFTWARE\Centrify\Cloud]
"AutoUpdate.Version"=dword:00000001

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