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KB-2947: Unable to login AD User to MacBook Air via Wi-Fi

Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:11 AM

Applies to: Centrify DirectControl for Mac OS X

 

Problem:

After joining a MacBook Air to Active Directory using a Wi-Fi connection, AD users are unable to login. 

Entering username and password results in a shaking password box at the login screen
 

Cause:

This is an Apple bug (Apple Bug ID# 12800468). The cause is due to the wireless adapter turning off at the Login Window. 

Because the MacBook Air hardware does not have any built-in ethernet ports, the primary network connection is using a wireless adapter (AirPort). 

This means that any "new" user login will fail to authenticate as the Centrify Agent at that point will be running in Disconnected mode with no cached users. 

If there is a user in the AD cache, it will allow login for that user only. 

Once the user is logged in, the wireless adapter should continue operation and the Centrify Agent will switch to Connected mode.

 

Solution:

1. If a USB Ethernet adapter is connected to the MacBook Air, the login window will have an active network connection and resolves the issue of lost wireless connectivity.

 -or-

2. Login with a local account and manually download user credentials to the local cache by entering the following Terminal command for the specified user:

   login adusername  (where adusername is the name of the AD User account)

After the user credentials have been copied to the local cache, the AD user should now be able to login without issue

 

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