Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-2517: Centrify Samba fails to install on Solaris 9

Centrify DirectControl ,   Centrify DirectControl Plugins ,  

12 April,16 at 11:44 AM

Applies to:
 
All versions of Centrify Samba on Solaris 9 platform.
 
Question:
 
When installing and running Centrify adbindproxy.pl, the following error occurs:
 
WARNING: Could not find Patch Check (PCA) script.
If you want to check this computer for missing required patches, please copy
all PCA files (or pca directory) next to the adbindproxy.pl and rerun this shell
script.
 
Do you want to continue? [Y] :
Using (Y)
ld.so.1: smbd: fatal: libc.so.1: version `SUNW_1.22' not found (required by
file /opt/centrify/samba/sbin/smbd)
ld.so.1: smbd: fatal: libc.so.1: open failed: No such file or directory
 
Please input Centrify Samba's path : ./adcheck yourcompany.com
 
 
The Solaris server is completely patched, is there any reason for this?
 
Answer:
 
This can happen if the wrong package for Centrify Samba is chosen. Centrify provides 2 packages - one for both Solaris 8 and Solaris 9, and the other for Solaris 10.
 
In the above case, the user chose the Centrify Samba package meant for Solaris 10. Choosing the right package resolved the issue.
 
Additional info:
 
1) For Solaris 10 or above, install Centrify Samba for ZFS build on sol10(sparc and x86)
 
2) For Solaris 9 or below, install Centrify Samba for UFS build on sol8(sparc)  or sol9(x86).
 
So each platform corresponds to a specific unique packet.
 
A) If customers install ZFS CDC-Samba build on sol10 on Solaris 9 or below machine, they will encounter CDC-samba failed to install as seen above.
 
B) If customers install UFS CDC-Samba (build on sol8(sparc) or sol9(x86)) on Solaris 10 or above machine, they will see an error where "CDC-samba can not support ZFS"

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.