Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-2440: Collector failed to connect to the audit store with the error " The conversion of a varchar data type to a datetime data type resulted in an out-of-range value."

Centrify DirectAudit ,  

12 April,16 at 11:07 AM

Applies to:


Centrify DirectAudit 2.0.2 or below on Windows



Problem:


The collector is unable to connect to the auditstore database with the following error:


===


[Tue 05/22/2012 04:56:06.617 PM] collector.exe[1492,7] Verbose:

CollectorServer.SqlTrace: Error - System.Data.SqlClient.SqlException: The

conversion of a varchar data type to adatetime data type resulted in an

out-of-range value.

[Tue 05/22/2012 04:56:06.617 PM] collector.exe[1492,7] Verbose:

CollectorServer.SqlTrace: A .NET Framework error occurred during execution of

user-defined routine or aggregate "CollectorUpdate":

[Tue 05/22/2012 04:56:06.617 PM] collector.exe[1492,7] Verbose:

CollectorServer.SqlTrace: System.Data.SqlClient.SqlException: The conversion of

a varchar data type to a datetime data type resulted in an out-of-range value.

[Tue 05/22/2012 04:56:06.617 PM] collector.exe[1492,7] Verbose:

CollectorServer.SqlTrace: The statement has been terminated.  


==



Cause:


The collector tried to insert an incompatible datetime format into the database, which resulted an SQL exception and caused the collector service to fail.


Workaround:


1. Login to the Windows machine with the SQL service account. 


2. In Control Panel > Region and Language > Format tab > Change the locale to "English (United State)" and datetime format to "MM/DD/YYYY".


3. Restart the SQL service.


4. Restart the collector service


5. But if SQL Server used "Local system Account" 
In Control Panel -> Region and Language -> Administrative -> Copy Setting -> Check "Welcome screen and system accounts" -> OK


Then Restart the SQL Service



Resolution:


This issue will be fixed in a future release.



Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.