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KB-2200: Unable to join domain due to LDAP UDP not responding

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:45 AM

Applies to:

Centrify DirectControl 4.4.3 on all Mac OS platforms

 

Problem:

Adjoin is failing with LDAP UDP is not responding.  

Even though portqry shows that UDP port 389 is listening for LDAP query, Deployment Manager and ADcheck both complain that no Domain Controller can be found as the UDP port 389 has timed-out. 

 

No firewall is blocked and Windows firewall setting is Off.

 

Note this link provides more details on how portqry works http://support.microsoft.com/kb/816103

 

Cause:

In Windows 2008 IPv6 is enabled by default, but Microsoft good practices suggest disabling IPv6 - which in turn causes the UDP to become unresponsive.

 

Solution:

IPv6 needs to be enabled in Network properties, or follow this link http://support.microsoft.com/default.aspx?scid=kb;EN-US;929852 

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