Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-2097: ZPA 5.0 does not write log information to its debug log file.

Centrify DirectControl ,  

7 March,17 at 07:35 PM

Applies to: Centrify Zone Provisioning Agent 5.0 on ALL supported platforms

Problem:
When the ZPA Configuration Panel is launched and the "Turn debug logging" is checked, and  ZPA is restarted, it only writes a header to the log file. It does not write a log of it processing the Provisioning Group(s).

Cause:
When ZPA is installed, the registry settings for the logging service are setting the log filter to "^*Centrify ZPA". With the recent changes made to the Centrify logger service, there's no need to set the log filter in order to distinguish the ZPA logs from logs written by other Centrify operations.  In short, the filter should be set to  "^*"

Workaround:
On the windows machine in question,
1. Install ZPA and open the registry editor (on Windows go to 'Start --> select run and type 'regedit'). 
2. Navigate to HKLM > SOFTWARE > Centrify Common Settings > Centrify ZPA
3. Set the value for the registry key "LogFilter" to ^* (no quotes -see the snapshot below)

























 


















4. Go to Services (Start -> Computer (right click) then select 'Manage' --> scroll down to 'Configuration' expand --> select 'Services')  and restart the logger service
User-added image


Resolution:
This has been fixed with ZPA version 5.0.1-171 and above.

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.