Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-2086: Fedora Core release 3 is not supported anymore

Centrify DirectControl ,  

12 April,16 at 11:11 AM

Applies to:
 
All versions of Centrify DirectControl on RHEL 4.9 platforms only

 
Problem:
 
When using Deployment Manager (DM) or installing the Centrify agent manually on a Red Hat Enterprise Linux 4 with kernel 2.6.9-100 using the Centrify's install.sh script, the following error occurs. As a result, its not possible to install the agent. Checking on supported platform list (http://www.centrify.com/products/all-supported-platforms.asp), it is found that RedHat 4.x is a supported platform.  Is there any reason?
 
uname -a
Linux rhel49v1 2.6.9-100.ELsmp #1 SMP Tue Feb 1 12:17:32 EST 2011 i686 i686
 
The error from DM log is shown as follows:
 
***** *****
 
***** WELCOME to the Centrify Suite installer! *****
 
***** *****
 
Detecting local platform ...
 
ERROR: Fedora Core release 3 is not supported anymore. Exiting...
 
Error detected. More information may be found in the logfile
 
(location is /var/log/centrifydc-install.log).
 
Exiting ...
 
------ Output log ------
 
Execute id -u Result =0
 
 
install.sh ***************** rev = 2011 (4.4.3-420) ********************
 
Fri Aug 12 10:05:19 PDT 2011
 
ERROR: Fedora Core release 3 is not supported anymore. Exiting...
 
Error detected.
 
Exiting ...
 
EXIT CODE: 29
 
Execute sudo -p "Password:" sh -c "rm -f /tmp/args.awk.975" Result =0

 
Cause:
 
This is because the kernel build number breached 100. 
 
uname -a now reports:
 
Linux 2.6.9-100 while our code is checking for 2.6.9-1*

 
Workaround:
 
a) If customer is not using Deployment Manager (DM), the temporary workaround is to fix install.sh by locating and remove the below lines and re-running the install.sh script again:
 
==========================================================
        2.6.9-1*)
            ### OS_REV=rhfc3;;
            echo ERROR: Fedora Core release 3 is not supported anymore.
Exiting... | tee -a ${LOG_FILE}
            do_error $CODE_ESU;;
===========================================================
 
b) If customer is using Deployment Manager, please contact Centrify support for the updated packages and manifest file.

 
Resolution:
 
Fixed in Centrify DirectControl 4.4.4
 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.