Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-1838: Deployment Manager 1.1 installation requires .Net 3.5 or higher

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:11 AM

Applies to:

Deployment Manager 1.1 on all Windows platforms.

 

Question:

What is the minimum version of .NET required by Deployment Manager and where does Deployment Manager installer check for it ?

 

Answer:

Deployment Manager requires that the Windows machine is running .NET Framework version 3.5 SP1 or greater, and if it is not, the installer will exit with a warning message. Deployment Manager installer checks if the registry key "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5" exists and if the value of "SP" is 1.

 

For system that is having .NET 4.0, if .NET setup not complete and .NET 3.5 attributes had not been applied, DM installer will fail because registry key "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP" not set to 1 yet.

 

 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.