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KB-1806: Centrify DirectControl Console report crashes with COM exception errors

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

7 March,17 at 05:26 PM

Applies to: All versions of Centrify DirectControl Console.
 
Problem:
A "COM exception error" occurs when running the "Default Computer Report" using the Centrify DirectControl Console. Is there any reason?
 
Cause:
This is a known issue with Microsoft .Net framework. This may happen when the Domain Controller in question is overloaded. In the console log error report, you may see the following error:
 
Detail unexpected error message:
System.DirectoryServices.DirectoryServicesCOMException (0x800700EA): More data is available.
 
Centrify uses a .NET native function call called DirectorySearcher.FindAll() in our code and .NET throws this generic "More data is available" (ERROR_MORE_DATA) error when Domain Controller is overloaded or other reasons not exposed by Microsoft.
 
Here is the Microsoft KB article which talks about the issue :
http://support.microsoft.com/kb/833789
 
Workaround:
Please follow these steps:
 
1) Close the Centrify DirectControl Console.
 
2) First you need to check the version of .Net framework installed on your machine. Please contact your IT department to get this info. Based on the version of .Net framework installed, you need to replace the "mmc.exe.config" file located in C:\Program Files\Centrify\Centrify DirectControl\ and C:\Windows\System32.
 
3) Take a backup of C:\Program Files\Centrify\Centrify DirectControl\mmc.exe.config and C:\Windows\System32\mmc.exe.config file just in case you need to roll-back.
 
4) Depending on the version of .Net framework installed on your machine, please use one of the attached file(s) at the end of this KB article. Save it to C:\Program Files\Centrify\Centrify DirectControl\ and C:\Windows\System32\ as filename "mmc.exe.config" 
 
5) Please reopen Console and run the report again and you should not see any exceptions.
 
Resolution: 
None as this is a known issue with Microsoft and has nothing to do with Centrify.  Also please note that this KB is applicable to .net 4 as well (Use the .net 2 xml file).

Centrify Corporation does not take any responsibility for the content or availability of this link and it was provided as a courtesy.  Customers should contact the vendor if there are any further questions”.
 
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