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KB-1551: Access denied due to logonHours restrictions

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:02 AM

Applies to: DirectControl 4.4.0 on AIX 6.1, HPUX 11.23 IA/PA-RISC, Solaris 8, 9 Sparc 64 bit

Problem:
After upgrading to DirectControl 4.4.0, AD users are denied access logging into the Unix/Linux boxes via ssh/telnet/GUI and you may see the following message being logged into syslog when user login fails:


Feb 5 11:42:24 CentrifySun01 adclient[4754]: INFO <fd:17 PAMIsUserAllowedAccess> audit User 'justin' is not authorized: User 'justin' denied access because of restricted logon hours

Cause:
You may run into this problem with user accounts where the attribute "loginHours" is not empty specifically on systems where OS vendors deprecated %z out of strftime() function. Due to this our current version may sometimes not calculate the correct Time Zone, thus preventing user login.

Workaround:
Using ADSIEdit clear the logonHours attribute on the AD user object.

Resolution:
Fixed in DirectControl 4.4.1

 

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