Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-1308: Solaris patches required in DirectControl 4.3

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:11 AM

Applies to:  Centrify DirectControl 4.3, contained in Centrify Suite 2008 update 3.
 
Question:
 
Why does adcheck in DirectControl 4.3 check for more required patches on Solaris compared to 4.2.x? Are the 
 
patches / revisions optional?
 
Answer:
 
Adcheck & pca use the same centrify.xref files to check for required patches. This file has been updated in 
 
DirectControl 4.3 to remove old patches and replace obsolete ones with their replacements.
 
The revisions on the patches are for the most part optional, the revision that adcheck / pca  prints out as required 
 
is the one that is installed in our QA labs on which DirectControl 4.3 was tested.
 
Please see the attached Centrify.xref file and Sun’s Website for more information on each patch number.
 
The table below should help identify the minimum patch revision that we require.
 
 
PATCH    REVISION Required         Comment
108919    > 22           Yes                 dtlogin patch (for pam auth)
108920    > 22           Yes                 dtlogin patch (for pam auth)
108993    > 49           Yes                 LDAP2 client.             
109147    > 44           Yes                 Core dumps if less than 44
109326    > 18           Yes                 libresolv.so.2 and in.named.
110898    > 12           Yes                 csh/pfcsh patch needed for programs running csh
110934    > 24           Yes                 Package utilities patch.
112960    > 65           Yes                 If not above 32, adlient may not start in timely manner.
114224    > 04           Yes                 csh/pfcsh patch needed for programs running csh.
114225    > 04           Yes                 Same as above this for x86.
114349    > 05         Optional          If you have 113482-02 ( which is now obsolete )
114131    > 03           Yes                 pkginfo -v does not work properly if <version> is shorter than actual version.
                                                              Dependency check will fail.
119254    > 05           Yes                 Sol 10 Install and Patch Utilities Patch, tons of fixes, strongly recommend
                                                             the latest revision (65 )
119255                       Yes                 Install and Patch Utilities Patch
117480    > 01           Yes                 Installation issues when pkg checks
113319    > 25           Yes                 113319 has been obsoleted by 112960.
120011    > 14           Yes                  Kernel patch.
127127    > 11           Yes                  Replaces old patch 127111
128624    >12        Optional          If you have 108993-(49 - 67 ) ( which is now  obsolete )
138263    > 3          Optional          Do not need if you don’t plan to use NSCD, but highly recommended
112963    >25             Yes                 Linker patch. It should be 25 or above.
113579                   Optional          ypserv/ypxfrd patch.You can choose patch 113579-03 which supercedes  
                                                          113483-02 & which Centrify requires.          
 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.