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KB-1270: Why does migrating a local user to AD result in an adprintd message in syslog?

Centrify DirectAudit ,   Centrify DirectControl ,   Centrify Identity Service, Mac Edition ,  

12 April,16 at 11:02 AM

Applies to: Centrify DirectControl 4.2.2 on Mac OS X.

Problem:

After migrating users to Active Directory (AD), and even after deleting the local user, these error messages get logged to the Mac syslog every 10 seconds:

com.apple.launchd[161] (com.centrify.adprintd[3362]) Exited with exit code: 1
com.apple.launchd[161] (com.centrify.adprintd) Throttling respawn: Will start in 10 seconds

and the corresponding message shows up in the Centrify debug log:

adprintd[774][775]: DEBUG <username> /var/centrifydc/adprint/username: Cannot create socket: Address already in use

Cause:

If a local user ever sets up a printer using the Centrify printer plug-in and runs a print job, adclient creates a socket file which belongs to that user in /var/centrifydc/adprintd. After the local user is migrated to AD and the local user account is deleted, the socket file is still be owned by the deleted account. Therefore, when adclient tries to create a socket with the same user name but with a different UID, it will fail and cause an error.

Resolution:
 
1. Delete var/centrifydc/adprint/<username>

or

2. Change the owner of /var/centrifydc/adprint/<username> to the correct UID using chown. For example:

chown -R 10001 /var/centrifydc/adprint/user1


Additional notes: This can also happen if the attributes of /etc/centrifydc/centrifydc.conf file are changed to
'read-only'. You can change it to the default setting by opening a terminal and running 
#sudo chmod 644 /etc/centrifydc/centrifydc.conf  

This was reported by one of our customers.
 

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