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KB-11509: New installation of Centrify Direct Audit fails to extract SQL express 2016 fails with "Error 0x80004005"

Auditing and Monitoring Service ,   PC Auditing and Monitoring Service ,  

26 December,18 at 07:29 PM

Problem: 

When installing Centrify Direct Audit version 3.5.2 for evaluation(installing SQL Server express 2016), the error below is seen:

 
error seen when Direct audit fails to install SQL server express.

 
Cause:

The SQL installer is a self-extracting executable file(exe) and the self-extraction fails if the target extraction folder results into a long path. e.g. following path is too long,

             C:\Users\Administrator\Desktop\zip\Centrify-Infrastructure-Services-18.11-mgmt-win64\Centrify-Infrastructure-Services-18.11-mgmt-win64\DirectAudit\setup.exe
 

Workaround:

Please  shorten the path by extracting the zip file to C:\ , the installer will work just fine, for example;


          C:\Centrify-Infrastructure-Services-18.11-mgmt-win64\DirectAudit\setup.exe

OR:

Please install Centrify Direct Audit with using the ISO file at the Centrify download center: 
       https://centrify.force.com/support/CentrifyDownload


It looks like this:
ISO file
 

Solution:

This issue will be addressed in an upcoming release of Centrify Direct Audit

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