Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-11461: Centrify Yum repo fails with [Errno 14] problem making ssl connection

Authentication Service ,  

17 December,18 at 04:38 PM

Problem:

Centrify Yum repo is failing with the following error:
 
[Errno 14] problem making ssl connection


Cause:

On RHEL based systems (6.7 or older) when the above error is seen, it is caused by support for TLS 1.0 and 1.1 being deprecated for SSL


Resolution:

To force SSL to start using TLS v1.2, the following packages plus any of dependencies must be updated to the latest:
 
yum
curl
openssl
nss


From command prompt as root or root equivalent user run the following commands:
 
1) yum-config-manager --disable centrify.repo
2) yum clean all
3) yum update yum
4) yum update curl
5) yum update openssl
6) yum update nss
7) yum-config-manager --enable centrify.repo


Note:

For more information on the deprecated TLS 1.0 and 1.1 support, please see below link. (provided as a courtesy)
https://jfrog.com/knowledge-base/why-am-i-failing-to-work-with-jfrog-saas-service-with-tls-1-0-1-1/

For more information on using Centrify Yum Repo:
https://www.centrify.com/support/customer-support-portal/repos/

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.