Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-11225: Do CVE-2018-10933 vulnerabilities affect Centrify DirectControl?

Authentication Service ,  

19 October,18 at 08:33 AM

Applies to: All versions of Centrify DirectControl

Question:

Does the CVE-2018-10933 - Bypass SSH Authentication - libssh vulnerability apply to Centrify DirectControl and if so how is Centrify going to handle them?

===========
Description
===========
libssh versions 0.6 and above have an authentication bypass vulnerability in
the server code.  By presenting the server an SSH2_MSG_USERAUTH_SUCCESS message
in place of the SSH2_MSG_USERAUTH_REQUEST message which the server would expect
to initiate authentication, the attacker could successfully authentciate
without any credentials.

Answer:

According to the information: https://www.libssh.org/security/advisories/CVE-2018-10933.txt

The vulnerability affects SSH server using libssh (server side). And it has been fixed in libssh version 0.8.4 and libssh 0.7.6 to address this issue.

Fortunately, Centrify libcurl uses libssh2 – not libssh. Therefore Centrify DirectControl is not affected.
 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.