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KB-11132: Reloading on user pull down fails in 18.7 with Error: Unknown column: pvaccount-OwnerID

Privileged Access Service ,  

3 October,18 at 05:34 PM

Problem:
  
After upgrading the Centrify Identity Service (CIS), the following error appears when reloading the User profile:
  
Query has failed: System.NotImplementedException: Unknown column:pvaccount-OwnerID

User-added image

Cause:
  
This error is due to an incomplete update of the CIS database.

Workaround:
  
Rerun the Centrify Identity Service installer and select the Repair option.  It is helpful to generate a logfile for the repair in case it is required to troubleshoot any further issues.  Instructions to rerun the update are detailed in the Centrify-Infrastructure-Service-HA-installation-guide.pdf that is included in the zip file of the CIS download.

The overview of the instructions are:
1) Using Microsoft Failover Cluster Manager, move the cluster role to a secondary node.

2) On the primary node, using the local Administrator account in a Powershell script, run the installer with the arguments /l <logfile> as seen in the example image below.

 
i.e. PS> Centrify-Infrastructure-Service-18.7.exe /l c:\Temp\cis.log

User-added image

3) Select to Repair
 
User-added image
 
4) Follow the instructions and answer the prompts as detailed in Centrify-Infrastructure-Service-HA-installation-guide.pdf

5) Once finished, move the cluster roll back to the primary node and run the same process on the secondary node.

 
Resolution: 
  
This issue will be addressed in a future release of customer managed Centrify Identity Services.

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