Tips for finding Knowledge Articles

  • - Enter just a few key words related to your question or problem
  • - Add Key words to refine your search as necessary
  • - Do not use punctuation
  • - Search is not case sensitive
  • - Avoid non-descriptive filler words like "how", "the", "what", etc.
  • - If you do not find what you are looking for the first time,reduce the number of key words you enter and try searching again.
  • - Minimum supported Internet Explorer version is IE9
Home  >
article

KB-11129: Centrify DirectControl Enabled Active Directory Users Are Not Able to Login to Solaris 11.4

Authentication Service ,  

29 November,18 at 03:39 PM

Problem: After upgrading to Solaris 11.4 users cannot log into those servers. 

Errors similar to these can be found in the logs: 

Oct  1 09:30:27 soloris sshd[2689]: [ID 636228 auth.error] pam_unix_cred: illegal option (null)
Oct  1 09:30:27 solaris adclient[1058]: [ID 702911 auth.warning] WARN  <fd:25 sshd(2689)> /usr/lib/security/sparcv9/pam_unix_cred.so returned  (3)
Oct  1 09:30:27 solaris adclient[1058]: [ID 702911 auth.debug] DEBUG <fd:25 sshd(2689)> No session ID exists.​


Cause: The PAM changes on Solaris 11.4 are not compatible with Centrify DirectControl 18.8 and earlier. 

Workaround: Revert the Operating System to a version that is supported by Centrify.

Resolution: Solaris 11.4 will be start being supported in with the release of Centrify DirectControl version 18.11. 

Still have questions? Click here to log a technical support case, or collaborate with your peers in Centrify's Online Community.