Problem:
When creating a Profile in Infrastructure -> Discovery -> Systems -> Profiles, the Port Scan Discovery Method is grayed out.
Cause:
The Port Scan feature is first available in version 18.6. If the Centrify Connectors are older that 18.6, as seen in Settings -> Network -> Centrify Connectors, Port Scan will not be available.
Solution:
Update the Centrify Connector(s) to the latest version.