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KB-10263: Failed to enable Zendesk provisioning with error "Authentication to provisioning endpoint failed. Invalid credentials"

App Access Service ,  

10 May,18 at 11:31 AM

Applies to: All versions of Centrify Identity Service

Problem:

"Invalid credentials" error was encountered when verifying credentials for Zendesk provisioning with a correct Zendesk admin credentials:

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Cause:

According to https://developer.zendesk.com/rest_api/docs/core/introduction#security-and-authenticationPassword Access must be enabled in Zendesk Support admin interface for using Zendesk API. 

When enabling Zendesk provisioning, Centrify is calling Zendesk API with the admin credentials entered. The above error will be returned if Password Access has not been enabled in Zendesk Support admin interface.

Resolution

Enable Password Access in Zendesk Support admin interface at Admin > ChannelsAPI before enabling Zendesk provisioning in Centrify Admin Portal:

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